+25

Media Center incompatible avec (presque) tous les serveurs DLNA

laboxideale 2 years ago in Media Center updated 4 weeks ago 5

Depuis la sortie de la box 4K, sa fonction Media Center est documentée comme étant compatible avec les mêmes serveurs DLNA courants que la box précédente : TVersity, Twonky, Windows Media Player, XBMC, Serviio, FreeMi, avia...


Hélas, un dysfonctionnement fait que contrairement à cette documentation (et contrairement à la génération de box précédente) elle s'avère incompatible avec la majorité des serveurs DLNA du marché (dont ceux documentés ci-dessus par SFR comme "testés et reconnus" :-) ). D'après les retours et expériences des forums, on ne trouverait plus que Plex qui serait encore compatible.


Les utilisateurs attendent donc depuis très longtemps un correctif qui rende une compatibilité DLNA un peu plus standard et générale au Media Center de la box 4K, et conforme à sa documentation.

LaBox THD 4K

Sans aucun correctif apporté jusqu'à présent, on peut remercier des utilisateurs qui ont analysé ce qui distingue le rescapé Plex : la différence viendrait du port utilisé (54200 dans Plex au lieu de valeurs inférieures usuellement dans les serveurs concurrents... qui semblent des ports bloqués par cette box).

Des solutions de contournement consistent à modifier la configuration de base des serveurs DLNA qui se révèlent incompatibles afin de les faire fonctionner tout de même en utilisant ce port 54200 (ou une autre grande valeur de cet ordre...)

Par exemple, on trouve cette solution pour le serveur Twonky sur le forum SFR (ici). 

  • Modifier le fichier twonkyserver.ini dans Twonky/data ainsi :
[main]
# Visible name in the network
friendlyname=Twonkyserver

# Comma separated list of IP addresses to bind to (optionally can include a netmask e.g. 192.168.3.0|255.255.255.0 will match address range 192.168.3.x). Default: blank = all networks
ip=

# Watch changes in machine's network conf (1: yes, 0: no)
nicrestart=1

# Verbose level for logging
v=0

# Compile platform
platform=arm_marvell_le_softfloat

# Port of the http server
httpport=54200


# TTL for SSDP packets. Default: 4
ssdpttl=4

Plus tard dans la même discussion, une solution similaire pour le serveur Kodi a été proposée (ici).

  • Remplacer le port 1639 en 54200 dans le fichier C:\Users\...\AppData\Roaming\Kodi\userdata\upnpserver.xml ainsi :
<upnpserver> <UUID>2242a02-e4226-222f-3ug-7242gg24d1a3</UUID>
          <Port>54200</Port>
          <MaxReturnedItems>200</MaxReturnedItems>
          <UUIDRenderer>cgferd5-21f2-52ed-26fe-earr25baa566</UUIDRenderer>
          <PortRenderer>1155</PortRenderer>
</upnpserver>

Des solutions similaires peuvent certainement se décliner pour les autres serveurs DLNA bloqués par cette box.

Le même genre de solution se confirme (ici) pour utiliser le serveur Universal Media Server :

  • dans l'onglet "General settings" d'UMS, ligne "forcer le port du serveur (5001 par défaut)" : mettre 54200

Bonjour et tout d'abord merci pour cette astuce !

Toutefois je reste coincé...

Mon disque est un WD My Cloud, utilisant Twonky.

Ma machine est un MacBook pro, utilisant la console Terminal pour les commandes

J'ai réussi à trouver et éditer les "twonkyserver.ini", modifier le port http ainsi : ...

# Port of the http server
httpport=54200

... et enregistrer le fichier MAIS LaBox n'arrive toujours pas lire le contenu :-(


Or quand je ré-édite le fichier "twonkyserver.ini", la valeur du port est revenu à 9000 (valeur par défaut).

Je dois reconnaître que cela faisait des années que je n'avais pas pratiqué les commandes Linux, ssh, vi :-) peut-être ai-je raté une étape quelque part. Peut-être également que les valeurs par défaut sont rechargées à chaque reboot de mon disque externe.

Avez-vous une idée ?

@Ze Booggy, en effet, si vous avez bien vérifié (avant redémarrage) que la valeur était bien modifiée dans le fichier et qu'elle revient à 9000 ensuite, il semble clair que l'installation du serveur Twonky sur ce modèle de NAS WD My Cloud (re)configure la valeur automatiquement pour une raison qui lui est propre.

  1. Peut-être est-il possible alors de trouver "ailleurs" dans la configuration de votre NAS le fichier modèle, ou les paramètres de base, qui sont injectés dans la config du serveur Twonky au redémarrage.
  2. Sinon il est probablement plus simple d'installer la version de Plex disponible gratuitement pour votre NAS (en espérant que, comme sur les autres systèmes disponibles, elle se révèle directement compatible avec cette box sans reconfiguration) : https://www.plex.tv/media-server-downloads/


La même astuce du changement de port fonctionne aussi pour rendre le serveur Serviio compatible avec cette box. Cependant, comme l'interface de Serviio ne propose aucun moyen pour modifier ce paramètre, il est plus laborieux d'accéder à sa valeur tout au fond des fichiers de configuration du logiciel.

  • On trouve sur internet comment changer manuellement le port utilisé par Serviio
    • 1. dézipper serviio.jar file du dossier lib
    • 2. localiser le fichier serviio.properties
    • 3. modifier la valeur de webserver_port (par exemple 54200)
    • 4. rezipper le tout (en conservant le nom serviio.jar)
    • 5. redémarrer Serviio
  • On trouve dans la FAQ Serviio l'emplacement des fichiers d'installation à modifier, selon le système d'exploitation